Why is My Deactivated URL-Triggered Workflow Still Running with Default HTTP Response Instead of Returning a 404?

This topic was automatically generated from Slack. You can find the original thread here.

Ok, related to the oddity I saw with my Workflow yesterday, I see it again. I have a URL triggered workflow, https://eo8dkukowewth66.m.pipedream.net, that I used for a demo. It did GenAI stuff and returned JSON. I’m done with the demo so I edited the workflow and set it to NOT active. Pushed to production, etc. But now if you click the URL, it still runs, but with the default HTTP response. I do NOT see new events, but shouldn’t it return a 404 or something?

Does the workflow actually execute?

Or you’re surprised that the URL returns a 200?

This is by design, since the HTTP interface for the workflow is technically a separate resource. We’re making that more obvious in the future (to facilitate better logging / ability to link multiple workflows to a single HTTP interface). But you should be able to disable the HTTP trigger if you want it to 404.

please make it more obvious :slightly_smiling_face: