Why has my previously working node step involving the import of the Firebase SDK suddenly stopped functioning?

This topic was automatically generated from Slack. You can find the original thread here.

I have a node step that worked just fine yesterday. I had it running today without any changes and it seems broken. Cannot really tell why, but I assume it has something to do with the import of the firebase sdk. Here is the error (see screenshot). Here is the code (partially)

import admin from "firebase-admin";

export default defineComponent({
  props: {
    firebase_admin_sdk: {
      type: "app",
      app: "firebase_admin_sdk",
  async run({ steps, $ }) {
    // Enter values for the following parameters below this code step,
    // These get passed to the initializeApp method below.
    const { 
      region = "[firebaseio.com](http://firebaseio.com)",
    } = this.firebase_admin_sdk.$auth


Hey , I suspect this might be because of the firebase version. Could you try to use version 10.0.1 instead. So your import statement would be

import admin from “firebase-admin@10.0.1”

This worked. Thanks for the tip :slightly_smiling_face: