Why does Typescript build fail on Windows with WSL2 but work on Mac, causing component API call error 500?

This topic was automatically generated from Slack. You can find the original thread here.

Hey, me and were are working on this task today and found a problem.

I thing action are not able to build the typescript, I’m experiencing the same problem on my computer (Windows with WSL2), but @U03BBH9F5TQ can build normally on they own computer (Mac).
When I build and try publish I received the error “component create api call responded with status: 500, body: {“error”:“unexpected error, please contact support@pipedream.com”}”


I was able to build it and in my comment I shared screenshots of the action working on pipedream’s UI

But for some reason, the github action says it’s not publishable

cc can you help troubleshoot?

Yep just a sec

re: building in windows: can you try deleting the dist folder in components/formatting and then build again? I got it working after that using windows like Alyson’s screenshot
re: why it fails in GH actions – still checking

Yeah, I tried and don’t worked :confused:

I believe that, if we merge it should work despite what github action says

Not sure what will happen, but I think we can try!

it may not work, future PRs may fail in GH actions because of this merge and we will have to fix the github action

I don’t think it will affect future PRs because only the changed files in the PR are verified

Only if the PR changes a component in formatting