Why does the workflow error email contain an invalid link redirecting to the wrong page?

This topic was automatically generated from Slack. You can find the original thread here.

I’ve noticed that when a workflow (not in a project) triggers an error the email contains an invalid link back to the workflow. For example, the email contains this link https://jghphqxl.r.us-east-1.awstrack.me/L0/https:%2F%2Fpipedream.com%2F@%2Fp_o7C5oMm%3Fe=2edfegqdlfIePfXgkCkiSSNrHw2/2/0100018ea96ebe8d-2b3809bc-07f1-4385-be18-1e581dca297b-000000/rZxRUkr2JWBYByZTB0FOHEtflWw=368 which gets redirected to https://pipedream.com/@nachocab/projects?e=2edfegqdlfIePfXgkCkiSSNrHw2 instead of https://pipedream.com/@nachocab/p_o7C5oMm/edit?e=2edfegqdlfIePfXgkCkiSSNrHw2

Are you talking about the standard error emails? I just tested on my end and got the expected result, which links to the event in Event History

Thanks, . Yeah, I think you created a v2 workflow. It might have something to do with v1.

Several years ago, I customized the Global Error Workflow to include this URL:

this.eventUrl = `https://pipedream.com/@/${workflowId}?e=${eventId}

and, like I said in my original message, it recently started expanding to https://pipedream.com/@nachocab/projects?e=2eiSX6k4fQNyuoo7mIaTfIxI2VB

I just tried expanding the @ to my username:

this.eventUrl = `https://pipedream.com/@nachocab/${workflowId}?e=${eventId}

And now it redirects to this URL https://pipedream.com/@nachocab/p_aNC71e?e=2eiSdAzeuODOxuTThvmODsjpFQd, which is what I wanted.

The weird thing is that it gives me a 404, but if I reload the page, it shows me the correct page. :man-shrugging:

I see in your screenshot that the default URL might have changed. I tried using this, but it didn’t work (after reloading the page, the 404 stays): https://pipedream.com/@nachocab/event_history/2eiSdAzeuODOxuTThvmODsjpFQd

Can you try /event-history/ instead of /event_history/ ?

And this structure works for me, to link directly to the trace in the inspector instead of Event History, if that’s what you want:


Here’s an example:


Redirects me here in my case since it’s in a project:


But the same URL works for a workflow that’s not in a project

I tried with event-history and got an error

I also tried with inspect and it’s stuck in “Waiting for events” because it’s a v1 workflow. It’s okay though, I can get by with my approach. Thanks, anyway!