Why does referencing a record ID via "Copy Path" throw an error in the "Update Airtable Record" step?

This topic was automatically generated from Slack. You can find the original thread here.

Hi there, i have a step “Update Airtable Record” and it throws the Error:“INVALID_RECORDS - 422 - You must provide an array of up to 10 record objects, each with an “id” ID field and a “fields” object for cell values.”

The trigger (a webhook) serves the recordID as follows: rec29FpH7I0rKpTxn

If i put the recordID itself it works fine if i reference it via “Copy Path” it throws the error

If i make an array of it [{‘id’:{{steps.trigger.event.query.recordID}},‘fields’:{}}] it also does not work

Hi Wilhelm, are you also referencing fields in the Update Airtable Record props?

For example, I passed a reference to a record by ID like you did, but I also made one small change to the record.

Hi, I also changed one field, but no difference.

I have made a new workflow and changed the trigger, still not working

I have switched to another Pipedream Account, same Error there. I have no Idea what i could try next :slightly_smiling_face:

I build a workaround: I pass a “selfmade” record id to the webhook, next step i list records with that id via filterByFormula, then i use the received recID to run the update Record step. Works. Seems like the trigger has an issue with the recID value, format or whatsoever. If you can provide a solution or find out why i have this behaviour i would be pleased if i get noticed. Thnx for your support and the awesome product - love it!

Glad you hear you found a workaround.

I believe perhaps you may have a formatting issue with the original method.

I suspect it’s not passing in the record ID as you think it is.

I’m able to pass a recordId from a webhook and it’s updating the corresponding record: