Why Can't I Delete Multiple Data Stores from My Basic Account?

This topic was automatically generated from Slack. You can find the original thread here.

Unable to delete data stores. I have an account on basic, it had 3 data stores (some for testing). With the changes to them around pricing i was removing the unneeded ones. I was able to delete 1 but when i try to delete a second one it prompts to confirm i enter the name and then click the delete button. I get the spinning on the button to say it is being actioned but it doesn’t actually delete. I have been able to change the name and modify the data store but it wont delete. I waited to day or so to check but i just tried to delete again now with no change

Hi , I tried to reproduce your issue but couldn’t. I can delete my datastore just fine in my free account.

Would you mind sharing your Pipedream account username for me to investigate further?

I was wondering about this too. I have a paid account and I can’t delete any data stores. I don’t see a feedback in the UI. When I click delete in the confirmation window, it closes but nothing happens. Then I refresh the page and the data store is still visible.

@U02MEBMQ8Q7 Thought I would give you guys an update. I just tried again and got a new error “cannot delete data store when connected to workflow”. This is new, I had tired deleting with it connected and not connected to a workflow as i found an old bug thread around that.
I was able to delete it when i removed it from a workflow now.
Looks like an update had been pushed to pipedream. Blessing give it a go and see if its now possible for you aswell.

Hi . Thanks for checking back again! Glad that it worked for you now!

Yes the Pipedream team has pushed the fix recently to fix this issue. Please feel free to let us know any other issue you faced!