Why Am I Unable to Read an Image Using Google Gemini Despite Successful Trial with GPT4?

This topic was automatically generated from Slack. You can find the original thread here.

Hi sorry in advance if here is not the place for post my issue:

I am trying to read an image using google gemini. But I am getting:

ENOENT: no such file or directory, open

I tried the:


So, do not know really how to get the image.

Thanks for your help.

Edit: I used GPT4 for the same purpose with no issues.

can you help?

It seems like your question is incomplete. Could you please provide more details or clarify what specific help you need with Pipedream?

I am sending a picture using webhooks. I can see the URL of the picture in the path. But when I try to generate text from the image using google gemini. I am getting an error of the path location. This is a screenshot of the error:

As I mentioned above, I tried different paths to get the tmp folder, but really don’t know what I am doing wrong.


In the message error I got the URL of the image inside [] brackets. Don’t know if this helps.

Google Gemini Account
Google Gemini
Prompt Text
What is this picture about?
Image File Paths
[ "tmp/https://......png" ]