Why am I Receiving a "Self-Signed Certificate in Certificate Chain" Error When Selecting a Schema on a New Source Using an Existing Postgres Database?

This topic was automatically generated from Slack. You can find the original thread here.

I’m setting up a new source using an existing Postgres database that works fine with other sources. When I try to select a schema, I keep getting the error “self-signed certificate in certificate chain.” I get that it has to do with the SSL cert, but all of my other sources using this database are working fine. Any thoughts?

Hi Ben, which Postgres trigger are you using?

Hi Pierce! New or Updated Row

Got it, thanks. I’m not seeing an option to override the SSL requirement either.

We are working on a improved version of these sources/actions for database integrations specifically, but I don’t believe that’s the cause.

These actions/sources make direct connections from the workflow, without a proxy inbetween.

But just to be sure, are you using workflow VPCs?

no I’m not

Got it, just wanted to confirm.

Could you please start a support ticket here about this SSL issue: Support - Pipedream

We will be announcing the new Databases support in the announcements channel when it’s ready, and it will be a huge improvement over the current integrations.

cc FYI ^

thank you all! I’ve submitted a ticket as well

Hi , can you create a new accoutn connection for PostgreSQL, and set SSL Verification Mode: Skip Verification , and try setting up the new source? We made some changes which by default enforces verification if a ca is provided, so you will need to override the default for this to work.

that worked, thank you! I didn’t realize there had been a change, but this resolved it

Working on updating the error message so that it is clearer as to how to resolve the issue. Thank you for flagging the issue!