Why Am I Not Receiving New Files (Instant) Trigger Event for GDrive in My Workflows?

This topic was automatically generated from Slack. You can find the original thread here.

Hi team , I am not getting event for New Files (instant) trigger for gdrive in my workflows looks like some bug. Please check.

Hi , I created a new source on my side and see the event emitted dor a new file just fine. Would you mind checking if you still have daily credit available?

Also could you share steps to reproduce your issue along with related information?

Hi , It works fine when we are giving drive as My Drive but i want to give Shared Drive, Can you once check that please ?

, my use case is whenever a new file is uploaded in the folder in my shared drive the workflow should trigger

For this I am using New Files (Instant ) Gdrive component and in Drive I choose the name of shared drive and in folder the name of the folder but when I upload the file I am not receiving the event.

Hi , do you notice any incoming logs when you add a new file to the folder in your shared drive?

Hi , no, i dont get any logs

Thanks for confirming. Looking

can you share the source ID? It starts with dc_

where can i find this id ?

Visit https://pipedream.com/sources and click on your source, then copy the ID from the URL

thanks for guiding . Here is the id dc_3pu0wJ6

We occasionally also run into this bug.

Sometimes it triggers, and sometimes it doesn’t.

Using Shared Drive as well.

Hi any updates on this ?

Sorry, not yet

I’ll let you know when I find something

FYI I submitted a PR!

Hi , it is still not fixed. Please let us know here once the issue will be resolved. Thankyou.

Hi , I merged and published it now (ETA 5min) as it was going through QA. Can you try again in a moment?

Hi ,the issue is still not resolved . I am not getting events when adding new file in shared drive

Hi , did you try creating a new source? Sources can’t update so creating a new one is required