Should the 'enabled_events' in my code be nested under 'stripe' to only receive specified events?

This topic was automatically generated from Slack. You can find the original thread here.

Hi,

  const { data: deployedTrigger } = await pd.deployTrigger({
    externalUserId,
    triggerId: "stripe-custom-webhook-events",
    configuredProps: {
      stripe: {
        authProvisionId: accountId,
      },
      enabled_events: [
        "invoice.created",
        "invoice.updated",
        "invoice.payment_failed",
      ],
    },
    webhookUrl: stripeWebhookUrl,
  });

The trigger is deployed alright only my webhook is receiving all events, not those from enabled_events .

Should enabled_events be nested under stripe here?

Hey , could you try to rename enabled_events to enabledEvents?

You can check Pipedream source for reference: pipedream/components/stripe/sources/custom-webhook-events/custom-webhook-events.mjs at master · PipedreamHQ/pipedream · GitHub

ah, I was working with stripe API via proxy before and there it’s enabled_events . Good catch, will try this :pray:

Nice catch, Leo