Send-message.mjs keeps giving me the same error

I haven’t changed my workflow since Apr 30, 2022, but yesterday I got the error “connect ECONNREFUSED”. The error is happening in the Send_Message step, with using a Discord webhook. The last time my workflow worked correctly was on Sep 12, 2022. After getting the first error, I noticed there was an update then I updated that step, but I am still getting the same error.

In testing the error was “connect EAFNOSUPPORT ::1:80 - Local (undefined:undefined)”.

The details in testing is the following:
at null.__node_internal_captureLargerStackTrace (internal/errors.js:412:5)
at null.__node_internal_exceptionWithHostPort (internal/errors.js:590:12)
at null.internalConnect (net.js:934:16)
at null.defaultTriggerAsyncIdScope (internal/async_hooks.js:452:18)
at null.null (net.js:1022:9)
at process.processTicksAndRejections (internal/process/task_queues.js:77:11)

1 Like

same problem here, has been happening since yesterday for me.

Thank you both for flagging – we are aware of the issue and are tracking it here [BUG] Discord Webhook Send Message Actions broken · Issue #4272 · PipedreamHQ/pipedream · GitHub

1 Like

FYI this is now fixed — unfortunately you’ll have to reconnect your account to the Discord Webhook app, then it should be working again :+1:

1 Like