$respond Not Working with HTTP API Anymore

Hello, I’ve been using this workflow successfully for a couple weeks now. I’ve utilized the HTTP API trigger in order to be able to use $respond to return specific information in the workflow. Today, I’ve been receiving this error on my steps with the $respond function which I’ve never seen before:

HTTP_RESPONSE_MISSING_IDThe workflow trigger is not compatible with $respond

I’ve tried to troubleshoot this by moving the $respond function elsewhere in my steps but I am getting the same error. While not a production workflow, this is slated for prod in the next couple weeks.

Can anyone provide me some insight as to why I would be receiving this error if I am using the HTTP API Trigger and its worked just fine in the past. What can I do to fix this?

As a follow-up, I’ve copied the exact same code to a new workflow with a newly generated HTTP API trigger URL and it works flawlessly. I am trying to use Pipedream for future production workflows. I would like to understand why this happened, if something is misconfigured and if I can get my original workflow to work. Thank you.

Hi @anthonyzoblescinPDI would you mind sharing the original workflow with me so I can help troubleshoot? You can click the blue “Share” button at the top right of the workflow and share with danny@pipedream.com.

Hey @droosevelt, I appreciate you replying. I have shared the original workflow. The most recent events show the HTTP_RESPONSE_MISSING_ID error.

Thanks for sharing the workflow! It looks like most of the recent events that failed were replayed from the workflow inspector, and we think there might’ve been a bug on our end that would have caused the workflow to fail on $respond in that specific case. We’re releasing a fix for that issue now, so can you try again in a few minutes (either replaying one of the recent events or triggering the workflow)?

You’re welcome! Thank you for taking a look! I didn’t even think that it could be because I was replaying events. I appreciate your team deploying a fix right away. I’ll try to replay an event in a few minutes.

Hey @droosevelt, I have tested a replay event and the $respond function worked! Thanks for your prompt attention on this matter!

Nice! Glad we got it working for you!