Request a limit increase

Hi how can I increase my QPS to avoid 429 Too Many Requests I have a Professional plane
is it auto increase and now it should be increased or what exactly
The error is in the workflows and I need to increase the limit

Hi @mohxt404

First off, welcome to the Pipedream community. Happy to have you!

Happy to help you - what is the desired rate limit you’d like on your workflow?

maybe 30 for every workflow I create now or in the Future

Sorry @mohxt404 , we have to do this operation for each new HTTP endpoint - it’s not a setting I can across across your entire account for future HTTP endpoints.

Which HTTP endpoints specifically do you need updated with this higher 30 events per second rate limit?

look if I need to send all my request to 5 workflows only can you increase the limit for more than 100 for each one ? this would make it simple to me and for you ?

Hi @mohxt404 sure, happy to adjust 5 workflows rate limits to 100 QPS for you.

Just to make sure I’m adjusting to correct workflows, could you share the ID of each one that needs this increase?

You can find the ID in the URL of the workflow when you have it open, it starts with p_******.

Here is 6 ones and make it 150 please cause i may have other test needed :slight_smile:

@pierce tell me when you finish bro and I’m sorry for your time :pray:

Of course, happy to help :slight_smile:

All of those workflows have been updated to 150 QPS rate limit. Please let me know if you need help with anything else!

1 Like

@pierce , wish you fine , i test the webhook with this amount of request but still get 429 error
:sweat_smile: You sure about rising up the limit , all the request is in the image it’s not even More than 20

Hi @mohxt404

Are you sure that the 429 error is not coming from another service you’re sending data over HTTP to in your workflow?

1 Like

No I use https , should I try http ?

No sorry, I wasn’t trying to suggest HTTP vs HTTPs.

Is the 429 error coming from a specific step in your workflow? Perhaps the service you’re attempting to send data to or you’re trying to retrieve data from is rate limiting you.

In that case it’s outside of Pipedream control.

1 Like

There’s no problem in The service that i receive from and I send the request to telegram bot it have no limit too and the service that I received request from it have no limit too

Hi @mohxt404

Are you broadcasting messages with your Telegram Bot?

When sending messages inside a particular chat, avoid sending more than one message per second. We may allow short bursts that go over this limit, but eventually you’ll begin receiving 429 errors.

If you’re sending bulk notifications to multiple users, the API will not allow more than 30 messages per second or so. Consider spreading out notifications over large intervals of 8—12 hours for best results.

Also note that your bot will not be able to send more than 20 messages per minute to the same group.

1 Like

I’m trying to send messages to channel in fact so I think the limit is 20 after read your reply,
Is there any way using pipedream to re try the request the gave 429 error .
Ps : I don’t have much knowledge in that so if you can help with fixing one workflows and I’ll do the other :pray:t2:

Hi @mohxt404

You can solve this problem in a few ways, but I recommend changing your workflow settings to respect the Telegram API’s limits:

You can alter how frequently you run your workflow with throttling, I recommend you adjust that setting to slow down how frequently your workflow runs so you won’t hit these limits.

1 Like

@pierce thanks i’ll check that but I have a Q please :pray:
is there any other coast if I use the ’ Limit concurrency ’ ? will I pay more than my monthly subscription or it’s a feature in the paid subscription

Hi @mohxt404 , there’s no extra cost to using the concurrency and throttling features!

1 Like