Python lib psycopg2 fails to import


Trying to import a psycopg2 lib at the Python code step and it’s fails. May I ask for a help with that problem?

Hi @nktamanakov

Thanks for sharing the error message, it’s very helpful!

It looks like we might have a specific permissions issue with installing that library. Have you tried using the new magic comment importing system with this package? It might help bypass this permissions problem:

Hope this helps!

@pierce thanks for youe reply!

I’ve tried to add magic comment:

# pipedream add-package psycopg2-binary
import psycopg2

But step fails with the same error.

What can I try to do next? :slight_smile:

@nktamanakov sorry, looks like you’ve found a package that is built for an amd64 environment, and workflow steps run in an ARM environment.

Here’s another package that claims to support the Lambda architecture:

You can use the magic comment system to import it, but unfortunately due to the low level bindings of this package we may not be able to support it without a 3rd party building a Lambda version.

Hello there,
Is this resolved? I am facing the same issue, and the solutions offered above aren’t working.

Hey @pierce, tagging you here in case you missed to get a notification.

Hi @Madhav44

For this kind of issue, I highly recommend creating a Github issue here: Sign in to GitHub · GitHub

From there the team will be able to start to troubleshoot the compatibility for this issue.

Thank you! Will do that