"New Tweet Posted Matching Query" Fails with Unauthorized Error


I’ve connected a Twitter account with a consumer key and secret as well as authorized the application in the OAuth popup. The Twitter account shows up fine in the Twitter Account selector.

Yet, I’m receiving a {"title":"Unauthorized","type":"about:blank","status":401,"detail":"Unauthorized"} error when trying to create the trigger “New Tweet Posted Matching Query”. The error happens when I press “Create Source”.

I’ve reconnected the Twitter account to no avail.

Hi @niklas,

First off, welcome to Pipedream! Happy to have you.

May I ask are you in Twitter Free Tier? If this is the case, you can only use Create Tweet and Get User info action. The other actions and sour es will not be available to you.

The only way enable for you to create the source is to subscribe to a higher Twitter API Tier. We’re apologize for the cryptic error message though

Thank you @vunguyenhung for the quick reply. No, this account is on the paid “Twitter API Basic” plan.

If it helps, I’ve verified that my account has access by:

  • POST request to https://api.twitter.com/oauth2/token with consumer_key and consumer_secret as Basic Auth. Body: { “grant_type”: “client_credentials” }.
  • As response, I’m getting a bearer token.
  • This bearer token is passed in the auth header when doing a GET on https://api.twitter.com/2/tweets/search/recent. This is the same endpoint that “New Tweet Posted Matching Query” uses.

Thanks @niklas for confirming! I will ping our component dev regarding this issue. Please wait for a few hours until he’s available

1 Like

Following as I am having the same issue with a paid Twitter Basic plan.

To provide an update, I’m using the Twitter paid Basic plan. I’ve created my Twitter app and Pipedream connections several times with no problem but I continue to receive the same error when I go to Create Source. Before I pay for support is there a known issue at this time?

failed with status code 401:

Hi @ssellwood,

We’re apologize that you faced the issue with Twitter. Pipedream component dev is taking a look into this issue and we will get back to you asap :pray:

@ssellwood do other sources and actions work, using that same Twitter account connection in Pipedream? Which source specifically are you getting that error on?

Good question.
I just tried to setup “New follower received by user” and that failed with the same error.