Is There a Bug in the "add_a_worksheet_tablerow" Function with Excel?

This topic was automatically generated from Slack. You can find the original thread here.

I have read the documentation and even tried the PI bot, and I might have found a bug when using the function “add_a_worksheet_tablerow” with Excel.

Hi Ivan, I think you’re very very close.

But you may notice on the Excel action, that the Value prop’s description notes:

A 2 dimensional array of unformatted values for the table row…

The steps.node.$return_value appears to be a 1 dimensional array.

I would try following the format linked from that description.

I tried looking at TableRowCollection: add - Microsoft Graph v1.0 | Microsoft Learn but still can’t crack it :slightly_smiling_face:

It’s buried a bit, but I think this example bit clear things up:

const workbookTableRow = {
  index: 5,
  values: [
    [1, 2, 3],
    [4, 5, 6]

The values parameter needs to be a multi-dimensional array, where each array within the main array represents an entire row.

Can you show the Inputs tab please?


Thank you. The Values field needs to be a multi-dimensional array, not an object.

I shared the entire payload from the Microsoft docs as an example. The values property in that example lines up with the Values field in the Pipedream action.

So for example, you could try in your node step:

return [
    [1, 2, 3],
    [4, 5, 6]

tried it with just one

so it’s not the comma between the arrays

bug? :slightly_smiling_face:

Hmm perhaps maybe! :slightly_smiling_face:

You can report bug reports on actions and triggers here in our public Pipedream Github Repository:

A Pipedream team developer or community member will investigate and make a new version to attempt to fix it if they can reproduce the bug.

All Pipedream triggers and actions are open source, so you can also contribute your own fix if you’d like.

Learn about how to develop new and modify existing components here: Overview

thanks for your help