HubSpot account not working on production


We just launched our first workflow to production and we are getting the error ‘This app hasn’t been granted all required scopes to make this call. Read more about required scopes here:",“correlationId”:“26da05a7-4b42-4363-a254-28485f172fe9”,“errors”:[{“message”:"One or more of the following scopes are required.",“context”:{“requiredScopes”:[“contacts”]}}],“links”:{“scopes”:""},“category”:"MISSING_SCOPES

However, it looks like the contacs scope is included. Is this likely an issue with Pipedream or HubSpot? Any idea on how to fix this? It’s only happening on our production HS account (our sandbox environment works).

I have tried deleting entirely and re-adding it, but no luck.

Hi @alex-135501

First off, welcome to the Pipedream community. Happy to have you!

Could you try re-adding it one more time? I believe I spotted the issue and added the contacts scope appropriately on our end.

Thanks @pierce - whatever you did worked.

Great to hear, Hubspot recently updated their permissions scopes to be more granular, but they haven’t yet updated their error messaging.

But if you run into any more Hubspot API issues, please let us know.