How to Fix the Notion API Timeout Error that Consumes All My Daily Credits?

This topic was automatically generated from Slack. You can find the original thread here.

For the past two days, one of my sources has been consuming all my 100 daily credits, probably because of an error that is being displayed in the logs but I can’t figure out how to sort it.

Trigger: Notion - Emit a new event when a page in a database is updated.
The error:

RequestTimeoutError: Request to Notion API has timed out
at Timeout._onTimeout (/var/task/node_modules/@notionhq/client/src/errors.ts:109:16)
at listOnTimeout (node:internal/timers:569:17)
at process.processTimers (node:internal/timers:512:7)

The error happens several times a day until the daily quota is reached. I tried reconnecting my Notion account but it didn’t solve the problem. Any clues on what I could do to solve it?

It sounds like Notion is maybe taking too long to respond. Is that a custom source that you wrote, or this Pipedream registry source?

It’s the registry source. I noticed this started happening after those recent Notion Outages last week, any chance this might be related to it?

It certainly could be. Is it still happening?

Does it ever work, or does it always time out?

Yes, it’s still happening right now. It always times out. Before, some of them would work, but now it seems the source always fails. These are the most recent ones

I also tried creating a new source with the same action but the problem persisted

can you try to repro here?

Okay I’ll take a look now

Hmm even I set the interval to 1 minute and have it run for 30 mins, I still see the source working normally. I will ping Andrew for checking

I see in both screenshots, the source was created 3 months ago — can you try recreating that source within your workflow?

I tried that a few days ago, I will try that again now

sorry for the delay. I tried creating a new source, and the error persists

Thanks . I will share this issue with our Component dev to check

, for context, could you share the estimated number of pages in your database?

Hi, Leo! The database has 299 items. I tried running the same trigger on another database of mine and it worked fine

I see, maybe that’s the reason. I will share with the component dev also

the bottom ones were on a database called “logs”, worked fine. The top one was when I changed back to “Sessoes”

“Logs” has 227 items

Thank you so much for your help