How can I resolve an error connecting Google Sheets with Pipedrive?

This topic was automatically generated from Slack. You can find the original thread here.

Hi all,
I am new to pipedream. I am truggling and getting error when connecting google sheets with pipedrive. Error messages as follows:

Hi, could you share the configuration of your step?

The Inputs section in that bottom panel will show the actual rendered data passed to the step.

That might lead to a clue.

Thanks in advance for support

Same happens with creating new organisation and new deal as well

Thanks, and does the Input tab show the data you expect for the Name, Email properties specifically?

See “steps.trigger.event.newRow[14]”

Everything looks in order

Have you tried removing one prop definition at a time and hopefully narrowing down which is the culprit? I wonder if they’re not compatible for some reason.

Ok will try

I have a feeling that it’s the Visible to prop specifically

That’s dependent on that particular resource existing on your account.

Removed all except mandatory fields

Still error

I’m sorry, I’m not sure what else could be the issue.

The only other thought I have is that your Pipedrive account doesn’t have permissions to add people.

But if you’re certain your account has permission, please consider filing this as a bug: Sign in to GitHub · GitHub

I made zap with zappier and it worked (was different source when tested)