How can I re-enable "Notify me on errors" for all workflows and disable specific ones afterward?

This topic was automatically generated from Slack. You can find the original thread here.

A few of my workflows had errors recently which I wasn’t able to catch until I checked out the actual inspect log. I noticed that all my workflows have “Notify me on errors” disabled - is there a way to re-enable it on all my workflows at once (and then disable the ones not needed)

The default on new workflows is enabled, but these were all workflows that were “migrated” (?) from the old account structure to the new one.

Otherwise I will need to open each and every workflow on my account to enable it :grimacing:

Did you not disable that toggle for those?

I didn’t disable, I had it enabled on all my workflows when my account was on the old structure. With the change, my account was moved to a “Workspace” account and all of them are disabled :disappointed:

I helped setup an account for a friend, just checked and her account was upgraded to a “Workspace” account and Error Handling is disabled on all workflows there as well


Can you share the username of this other account?

Sent in DM.

this is the message that shows when logging in

My assumption is that during the migration the error handling setting was lost

If that’s the case it’s definitely not by design — checking on this asap.

FYI Zalman we confirmed this is a bug that occurred during the account migration process. The conditions in which it occurs are subtle, which is how it slipped by, so thank you for flagging!

We’re working on reverting that specific toggle on all workflows where it was inadvertently flipped now. No current eta. So if there are critical workflows that you want to make sure you are alerted about for errors, I’d flip it manually in the interim.

Got it, thanks for the quick response.