How Can I Get Google Sheets to Trigger When a Row is Updated?

This topic was automatically generated from Slack. You can find the original thread here.

Google Sheets | Trigger : Google sheets does not trigger when a Row is updated - please help :slightly_smiling_face:

The workflow only catches updated rows when I initially add the Trigger step - but does not work when deployed or refreshed in editor

I tried both the Shared Drive and standard triggers - neither worked :confused:

It seems like the request is being pulled in from the logs

But no events are displayed

Hello , maybe the change is not in your spreadsheet? Would you mind submitting a ticket for us with the reproduce steps

I submitted a ticket t he changes are 100% in the spreadsheet and as you see - being logged. For some reason the trigger is not catching the errors.

I just gave yโ€™all access to edit the workflow

, Iโ€™m not surecwhat you mean by just submitted a ticket and gave the access, would you mind clarifying?

I think I found the issue - the Sheet has to be public :slightly_smiling_face:

or maybe you have not gave Pipedream enough permisson when connecting to Google Sheet account. You can try to remove Pipedream from your Google Account Permission page and try to reconnect again