Error when selecting worksheet Google Form trigger

I’m seeing an error when setting up a trigger on Google Sheets (new row). I can select my account, the drive, the spreadsheet, but it fails to pull any of the worksheets to select one. I noticed the following console error:

Error: option value must be string or number
    at prop-input-connect-account.44742dc5.js:1:36272
    at ja (prop-input-connect-account.44742dc5.js:1:36333)
    at prop-input-connect-account.44742dc5.js:1:42900
    at (<anonymous>)
    at ReactiveEffect.fn (prop-input-connect-account.44742dc5.js:1:42892)
    at (vendor.aa4b3839.js:1:6454)
    at ComputedRefImpl.get value [as value] (vendor.aa4b3839.js:1:17012)
    at c (vendor.aa4b3839.js:1:78883)
    at ReactiveEffect.c [as fn] (vendor.aa4b3839.js:1:79257)
    at (vendor.aa4b3839.js:1:6454)

I tried reconnecting that account, but still the same. Any ideas?

Hi @byron2, we pushed out a fix that might have addressed this problem. Can you refresh the page and give it another try? If it’s still persisting, would you mind sending a screenshot with the error output visible and your JS Console open in your browser? (please be sure to blur / hide any sensitive information)


I’m no longer getting the same error, but now when I add a sheets trigger, it shows up as a webhook trigger and never receives the new rows.

Image 2022-01-17 at 9.17.29 PM - In this screen shot, this should be a sheet trigger.

Hm that’s strange indeed! Can you do me a favor and remove that trigger, then re-add the Google Sheets: New Row Added (Instant) trigger and see if the same thing happens?