"Create Transcription" from open ai gives "Invalid file format"

Going by this tutorial: How I Use AI to take perfect notes...without typing - YouTube

And for some reason it’s not passing through the file format properly. I’ve tried manually putting the format in the file path but still outputs the same thing. I’ve made sure to download the file to temp storage before trying the transcription. Also tried making new openapi api keys.

Appreciate any help.

Ok I’ve trial and error’d the problem and I’ve found that if I convert the same audio file to any format it works. Even when converting .m4a to .m4a; which doesnt make any sense. Basically what I’m doing is I’m recording audio from my Samsung watch and got an app to upload that to my google drive, then using pipedream to recognise new uploads and send that to openai transcription.

Not exactly sure why it acts like it has a invalid file format even though it clearly supports it. Maybe there’s something in the samsung watch .m4a recording that messes it up. Idk.

1 Like

I ran into the same issue recording notes with my samsung, I think the way samsung does file conversions is not compatible with whisperAPI.

1 Like

I’m working through this tutorial and am also getting the invalid file format error. Like yourself, I’m using a voice recorder app on a Samsung phone. Can you advise how you are converting the file format? Are you converting it on the phone or from within Pipedream?

Further to this, I can successfully download the .m4a file when I test the download_file step, however the mimeType returns with audio/mp4. I don’t if this related to the issue or not.

Any assistance is greatly appreciated,

$summary:Successfully downloaded the file, "Voice 003.m4a"
name:Voice 003.m4a

I’m using a different recording app on my phone called Easy Voice Recorder and it works well. I think it’s the type of codec it gets when recording that open ai doesn’t like with using the standard samsung app.

Hey Monoloid,
It’s possible that the codec used by Easy Voice Recorder might be more compatible with OpenAI compared to the standard Samsung app.
Have you found specific codecs that work better with OpenAI or any other recording apps for seamless transcription?

I wouldn’t know any specific ones tbh. I just found that app works and didn’t look further into it sorry.