Connection to Discord Error

After logging into discord to integrate it, i get this error:

This page isn’t working

If the problem continues, contact the site owner.


Any help? Tried on 2 different browsers.

Hi @anointed

A 401 error means your account is not authorized to view data or perform a specific action.

Does your Discord account have the sufficient permissions to add a 3rd party app or bot?

Yes I’m admin.

I assumed you’re seeing this 401 error on when trying to connect it via Pipedream.

I just authenticated and wasn’t able to reproduce the error unfortunately.

Could you share a short screencast of what you’re trying to accomplish? Maybe you’re trying something differently than I cam.

Sure, Loom | Free Screen & Video Recording Software | Loom

Hi @anointed

Thanks for the screencast, that’s very helpful.

So the issue looks like somehow you’re also attempting to create a webhook while connecting the Pipedream Discord bot.

That is not the normal prompt, it usually just asks to authorize the Pipedream Discord bot.

How are you getting to that initial prompt just before your screenshare starts?

I think the webook is old but i deleted it from the account. To get that prompt, I just click Connect Discord acount or whatever in the workflow action. Then it opens that window.

From “Pierce via Pipedream” <>
Date 9/13/2022 7:20:43 AM
Subject [Pipedream] Connection to Discord Error

Here is the bug report for our component developers to take a look:

I tried to capture your reproduction steps based what I gathered from this thread, but if it’s inaccurate please comment there so we can correctly reproduce the bug.

In the short term, you might want to try using the Discord Bot app instead, since it uses a different authentication method and should be separate from the main Discord app.

Thanks. Sorry for the lag. I am getting it on the non webook option that just says Discord as well. I never removed anything on the Discord end, just the Pipedream end.

I also dont see where it lets me send a channel message via Discord Bot, but ill just make a new account and use the original one. thanks.

Sorry, I used a different account and tried to connect it using just Discord. Same issue.

Sounds like you may have found a bug on a different area.

You can report bug reports on actions and triggers here in our public Pipedream Github Repository:

A Pipedream team developer or community member will investigate and make a new version to attempt to fix it if they can reproduce the bug.

All Pipedream triggers and actions are open source, so you can also contribute your own fix if you’d like.

Learn about how to develop new and modify existing components here: Overview