Bug in Add Row to Google Sheets, spreadsheet ID not working

Hi Team,

Recreate the issue:

  1. Create a workflow with Add Row to Google Sheets step
  2. Select Google Account
  3. Instead of selecting a particular Sheet from the dropdown, try to enter a string (or a reference). The step does not connect to Google to search for the sheet, and it won’t load the Sheet’s tables in the next field.

This Google account has more than 100 sheets, so there is no way to use some sheets unless I enter the Sheet ID directly. I know the sheet ID is correct because this all works if I use the Get Data step for Google Sheets.

I have made the Workflow available to support in my account (“Temp-Onboard-Workflow”).

Thanks for everything you do.

Hi @chadhively ,

First off, welcome to the Pipedream community. Happy to have you!

Thanks for bringing this up. We intended for the Use custom expression option to be a quick way to enter in manual data like this.

However, it appears there’s a bug that doesn’t allow to you use it in this way.

The team’s aware of this issue now and here’s where it’s being tracked:

Thanks for your patience! Sorry about that.

We’ve fixed this bug! @chadhively make sure to update the Google Sheets – Add Single Row action is up to date (the UI will prompt you to update the action if it isn’t), and give this another try.