Urgent: We cannot connect any applications

Suddenly, this morning, our XERO app (and some others) ceased to function. This has been working for 2 years already. We tried to re-connect it, and it brings up an OAUTH application to Google? The screen then says we are not authorized. Why is the XERO app now connecting thru Google? It seems like this app, and others are now broken and don’t authorize with the correct application. We tried deleting the Xero app and then creating a new one, but it’s the same thing. Same with Slack. All apps go thru an oauth with Google?
video link: New Recording - 7/26/2022, 11:26:19 AM

Hi @osseonews

Thanks for the report, we have an incident open you can follow here:

@osseonews we have just deployed a changed, you should be able to connect your XERO account and others, but if you cannot could you please let me know?

thanks. We can connect the accounts now, and we created new connections. Haven’t tested the workflows as we can’t replay them for various reasons. But, I’ll update, if the new workflows don’t work. Thanks for the quick response.

1 Like

Hi @osseonews thanks for your patience on that issue.

We were able to recover the vast majority of accounts affected by that issue yesterday, but if you still have issues please just let us know!