Speed - slowdown accessing Sheets

Hi,

My workflows seems to be taking a lot longer than they used to. I have a simple flow which connects to and queries a Google Sheet and returns a JSON response.

‘Cold’ starts used to take c. 10-12s, but thereafter I’d get sub 1s responses (once ‘warm’). Now they mainly take well over 10s, even when warmed.

Any ideas?

Thanks

Chris

1 Like

I have the same problem.

Hi,

Thanks for sharing the event log screenshot. That’s very helpful.

Have you limited concurrency on the Google Sheets integrated workflow? I can see you have multiple events incoming in a very short period of time.

If the workflow is still processing an event while another is emitted, then a second worker will spin up from a cold start to help.

You can try limiting concurrency, or increasing the number of active workers by increasing the “heartbeat” HTTP requests to 2x for example.

@martinschreiber and @chris-3335b7

Can you share links to your workflows and share them with support? The toggle is available under Workflow > Settings.

Done, the workflow: https://pipedream.com/@martinschreiber/lprcameratocalltoopengate-p_wOCYgxJ/inspect/2EhkVPnkfUv6OA22QHqpjFvULoR

I am just trying to find a way how to worm up the workflow.

Hi @pierce ,

Sure, the workflow is here:

We’ve not changed anything re: concurrency.

Thanks for looking at this,

Chris