Possible update needed on zoho_crm_create_object

Hi there,

Firstly, I’m not experienced with writing code, but I try very basic things. I’m trying to make a put request to my Zoho CRM from data in a Google Sheet. There might be an update needed for the"Zoho CRM" action when using the “zoho_crm_create_object”. I’m receiving an error. The error shows:

ErrorRequest failed with status code 400
  "details": {
    "api_name": "data"
  "message": "required field not found",
  "status": "error"

When I looked up what the issue might be, I found a possible fix here - https://help.zoho.com/portal/en/community/topic/mandatory-not-found-error-when-trying-to-insert-data

It said to do this:

Kindly map the parameter which carries the value to the respective field using the field API name.


In the above sample, consider First_Name and Last_Name as field API names, and consider first_name and last_name as variables which carry the values obtained from the parameters.

Thank you.

Any ideas or thoughts would be appreciated to help this issue. Sorry if I’m not writing the information down properly here in this forum. It’s my first time doing something like this.

Hi @wwc-776, thanks for reaching out!

It looks like Zoho may have changed their API at some point since we published this Action and that’s what is leading to the error you’re encountering. I updated this Action and confirmed it’s working for me now. In order to fix this on your end you’ll need to remove the existing Action step and re-add the same one (“Zoho CRM” → “Update Object”).

Let me know if this works for you!

Ok, I thought it might have something to do with what you just explained. I’ll try doing what you suggested. Thanks for replying to me so quickly. I really appreciate it.

Hi droosevelt,

I tried doing what you suggested, but it’s still giving me the same error message. Any thoughts?

Would you mind sharing your workflow with me so I can take a look? You can click the blue “Share” button at the top right and share with danny@pipedream.com.

Ok, I’ve shared the workflow with you. Thanks for taking a look at this. The step that is deactivated is the one giving the errors (zoho_crm_create_object)

Ah thank you for sharing – we had fixed the issue with the update_object Zoho CRM action, but I see you’re using the create_object action. I just released a fix to that action as well, so please go ahead and remove the existing Zoho action in your workflow, then re-add that one again and give it shot!

I just tried re-adding the object and it’s working!! Thank you for taking the time to help me with this issue. I really appreciate it! Keep up the good work with Pipedream. It’s a great service!

Great to hear and thanks for reaching out!