Pipedream Internal Error - old workflow stopped working

Hello,
I have a workflow that has been working correctly for the past year but has started returning
Pipedream Internal Error – Please retry your event or reach out to Pipedream support at https://pipedream.com/support/ if this error persists

Can you advise what might have changed? other similar workflows are continuing to work https://pipedream.com/@hussainm/get-time-duration-last-week-kamal-v2-p_OKCY3JG

Has anything changed recently that might cause this?

Hi @hussainm

First off, welcome to the Pipedream community. Happy to have you!

Thanks for reaching out. Sorry for the opaque error but I believe I have spotted the issue.

On line 32 in your steps.clickup_getTeamMembers step, there’s an invalid number defined:

sevenDaysEarlier.setHours(19,00,00)

The error was happening during deployment, not at runtime. Our lambda runtime was throwing an error when trying to read that line of code because 00 is not a valid number in Javascript.

It’s funny how time throws tricks on our brains like that, the equivalent in Javascript for minute 0 is 0, not 00.

Hopefully replacing that number fixes it for you!

Thank you, so much! That fixed it.
Though its strange that the error only started cropping in the last month perhaps on a recent deployment, it has worked for the last year.

@hussainm

I believe the underlying JS parser tool we use to build your workflow picked up on the deprecation notice:

Under the hood, I think the strict mode is applied, which is causing this exception when building the lambda.